Shop Mobile More Submit  Join Login


Closed to new replies
December 31, 2012


Replies: 3

Wireless Connection lag on G73 Laptop

Azeron17 Featured By Owner Dec 31, 2012  Hobbyist General Artist
So, I've been experiencing this odd issue on my Asus G73 Laptop for quite a few months now. After I boot into Windows 7 Professional, and everything seems ready to go, my wireless connection to my router takes about a minute to connect. Before it connects my entire computer just works very slowly, Winamp will launch but only to a blank library, My Computer has the magnifying lens load in Explorer but I can access all my libraries and other directories. Once that minute is up, everything just goes back to working as it should.

I thought it may be MAC Address Filtering since this started around the time I implemented it on my home network. The only issue I have with that theory is that my desktop, TV, printer, tablet and phone all load up with zero lag. Now that I think of it, I've turn filtering off before and it seemed to get rid of the issue, at the cost of my peace of mind.

I'm also on an Asus router too after switching from a Netgear experiencing the exact same issue. This is the only device with WiMAX on it so I'm not sure if it's just an internal issue.

Any ideas as to what the problem might be?

OS: Win 7 Pro 64-bit
Laptop: Asus G73

You can no longer comment on this thread as it was closed due to no activity for a month.

Devious Comments

PR-Imagery Featured By Owner Dec 31, 2012  Hobbyist General Artist
Look at what programs load at startup, the lag and slow down is most likely caused by some program loading or everything that is loading at startup.
Disable all your startup programs and see if you still have the issue.
Azeron17 Featured By Owner Jan 8, 2013  Hobbyist General Artist
Thanks for your suggestion, I just haven't been able to look to far into it yet. Or rather, I'm on vaca and haven't really wanted to figure it out yet.
snoowie9 Featured By Owner Jan 1, 2013  Hobbyist Photographer
Jou van find those in msconfig just type that in te search area in type start menu
Add a Comment: