Deviant Login Shop  Join deviantART for FREE Take the Tour

Details

Closed to new replies
December 6, 2012
Link

Statistics

Replies: 3

Linux/Kubuntu: How NOT to wake laptop when opening lid

:iconxternal7:
xTernal7 Dec 6, 2012  Hobbyist General Artist
Yeah, that's right. I'm looking for a way to disable lid switch from waking my laptop, as it does that way better as it should. I've set my laptop to sleep, put it in my backpack, only to find it up and running after a while. Lid switch is definitely causing this problem, and I'm now looking how to prevent it from waking the laptop (hardware fix is the last option).

I've did my bit of homework, and found that I might want to look for LID in /proc/acpi/wakeup. The file looks like this:
P32 S0 *disabled pci:0000:00:1e.0
KBC S3 *enabled pnp:00:08
MOUE S3 *disabled pnp:00:09
CIR0 S5 *enabled pnp:00:0a
UHC0 S3 *enabled pci:0000:00:1d.0
EHC1 S3 *enabled pci:0000:00:1d.7
UHC3 S3 *enabled pci:0000:00:1a.0
UHC4 S3 *enabled pci:0000:00:1a.1
EHC2 S3 *enabled pci:0000:00:1a.7
EXP2 S5 *disabled pci:0000:00:1c.1
PXSX S5 *enabled pci:0000:03:00.0
EXP6 S0 *disabled pci:0000:00:1c.5

And nothing even remotely resembles "LID". So I tried to disable ALL the things, restarted acpid, but the thing still woke from sleep when I opened the lid. (And needed a restart because session completely froze, at which point everything got reset).

I've then went thermonuclear on any script that could be connected with lid actions. So far, I've totally commented every single line in /etc/acpi/events/lidbtn and /etc/acpi/events/lid.sh and the problem still persists.

I've also found a directory "/proc/acpi/button/lid/LID0/", which stores file "stats". In that file, lid state is recorded (and does indeed change with opening/closing a lid, verified with external monitor). I've made no further progress.

Help, please?

Laptop model: HP pavilion DV7 2250em.
Reply

You can no longer comment on this thread as it was closed due to no activity for a month.

Devious Comments

:iconpyrohmstr:
pyrohmstr Dec 6, 2012  Hobbyist Digital Artist
Try a: sudo update-grub

Also, [link] will help with the hardware stuff. One of those in the list is your lid button, it's just not listed as such. I used i-nex once on my RaspPi and it worked well enough :p
Reply
:iconxternal7:
xTernal7 Dec 7, 2012  Hobbyist General Artist
sudo upgrade-grub did nothing. And unfortunately, the i-nex won't run either... :(

Also: RaspPi? As in, Raspberry Pi? If that's the case, I'm thinking of getting one, too. What OS do you run on it?
Reply
:iconpyrohmstr:
pyrohmstr Dec 7, 2012  Hobbyist Digital Artist
I had to compile i-nex from source :shrug: I don't know, there are other hardware information tools out there.

Yeah, Raspberry Pi. I have Debian on it right now. Well, I fried my SD card doing some IO benchmarking the other day and I've been too lazy to sort that shit out. I really need to because my RaspPi is my ARM testing thing. Fucking ARM ISA :shakefish:

Anyway, it's a fun little thing.
Reply
Add a Comment: