Shop More Submit  Join Login

Details

Closed to new replies
August 1, 2011
Link

Statistics

Replies: 10

"Failed to save canvas" Painttool SAI Problem

:icontv-show:
TV-SHOW Featured By Owner Aug 1, 2011  Student Filmographer
Helloo, I am in desperate need of help.
My Painttool Sai won't let me save in any other format than .psd!
It's been doing this several times, and sometimes it just stops and works fine again. But soon enough it starts to display the error once again. The message that pops up just says "Failed to save canvas"

NO IDEA what triggers this or how to get rid of it. I found a string of comments on an old thread here on dA with the same problem ( [link] ) but the thread seems to have been deleted? I don't know.
Anyhow none of the solutions in the thread helped whatsoever :(

And I can't save it at psd and then save it again as jpg in photoshop since the layers gets messed up with the layer clips and filters >>

I already tried exporting it instead of saving it, disabled custom file viewer, alt+tab, saving several times in a row but nothing workkksss! >-<''


Help is very appreciated!! <3
- TV
Reply

You can no longer comment on this thread as it was closed due to no activity for a month.

Devious Comments

:iconsayuri-lilly:
Sayuri-Lilly Featured By Owner Aug 2, 2011  Student Digital Artist
Just bumping this forum post up since I had a simular problem once before as well. It'd be nice to know what the cause is.

But based on what I experienced I found that simply clearing your computer of any SAI files tends to fix it for me and I litterally mean every single file. Even I came across the odd stray file in a place I didn't realise I saved at. If you have a portable hard drive, DVD/CD/Disk to store your work on it might be worth trying, just to see if it improves anything. I don't ever save in SAI format anymore because of that, PSD format is no different I feel. Unless you use things like the pentool then I don't think PSD supports the SAI vector lines, might be wrong though since I don't use the pentool on SAI that much :B
Reply
:iconjinyuu:
Jinyuu Featured By Owner Aug 1, 2011  Student Digital Artist
Save the file on your desktop?
Paintool sai only lets me save files on my desktop...if not it won't let me open them. Hope that helps...probably not.
Reply
:icontv-show:
TV-SHOW Featured By Owner Aug 1, 2011  Student Filmographer
I tried that, doesn't work D:
Reply
:iconjinyuu:
Jinyuu Featured By Owner Aug 2, 2011  Student Digital Artist
Ah :/ well i dunno what to do, sorry hun
Reply
:iconzannyhyper:
ZannyHyper Featured By Owner Aug 1, 2011  Professional Digital Artist
I've had this problem alot too,what I do is go to file > export > PSD for some reason it'll let you export rather than save, it works for me xD
Reply
:iconsummermon:
summermon Featured By Owner Aug 1, 2011  Student General Artist
Mine does this all the time on my laptop.
it sometimes will fail to save, and sometimes when it opens a picture it comes up blank.

given, mine isn't exactly a legitimately obtained copy of the program... OTL

the only thing I can really suggest is merging it all into one layer, copying the whole thing and pasting into another program to save. /: but that doesn't work with filters, so...
screencapping parts at a time and then putting them together in another program works too, but the sizing and making sure the pieces are put together right is difficult, and a bit time consuming...
asdfghjkl;.
I hope somebody gives you a better option. x__x
Reply
:iconzeerostars:
zeerostars Featured By Owner Aug 1, 2011  Student Digital Artist
Ahhh, I got almost the same problem. I had a drawing that I worked on, and now I can't open the file because it is a .sai file. I can open other files, just not .sai! D: Sorry I'm not much of help, but I'm really sure a lot of other people have the same problems. OTL
Reply
:iconblitzkatze:
Blitzkatze Featured By Owner Aug 1, 2011  Hobbyist Digital Artist
Hmm, and odd problem indeed, I never had any problems with my SAI before, but I found some things that might help you.
Someone on another forum said that he changed the options of the folder he was saving his files in, so he was unable to save them there anymore, after he changed this options everything was fine again.
It could also be the version of your SAI, maybe you just need to update it from 1.1.0 to a higher version.
If nothing helps I would suggest to reinstall the whole thing.

Let me know if this helped you, so I can search a little bit more if you still have trouble :)
Reply
:icontv-show:
TV-SHOW Featured By Owner Aug 1, 2011  Student Filmographer
I couldn't find a way to update it, a friend gave me a cracked version to stick with until it works again <:I
But really I couldn't find any other versions than 1.1.0? o-o
Reply
:iconblitzkatze:
Blitzkatze Featured By Owner Aug 1, 2011  Hobbyist Digital Artist
Hmm yeah, you're right, maybe the person in this forum just mixed up 1.1.0 and 1.0.0.

I also found this here "Try deleting the directory on C:\Documents and Settings\All Users\Application Data\SYSTEMAX Software Development and also the registry entries for SAI, maybe with a fresh start SAI will start right for you. " But I have no idea if it works or not.

Does it work if you save your files direct on the desktop? Some with the same problem are still able to do this.

And like I said, maybe it will work again if you deinstall it and delete all related files and reinstall it again.
Reply
Add a Comment: