Shop Mobile More Submit  Join Login

Details

Closed to new replies
December 24, 2012
Link

Statistics

Replies: 11

Canon EOS 450d no longer connects to Mac

:iconmutanteyeball:
mutanteyeball Featured By Owner Dec 24, 2012
I have had this camera for several years, and have had no problem connecting it to my computer to both upload images and use computer control, until yesterday.
Now, when I try to connect, the camera displays the "busy" signal, then reverts to normal shooting mode and I am unable to access it via my computer.
I have tried using different USB ports and cables to no effect, the rest of my equipment connects fine.
I am still using the same OS and have not received any recent software updates.

Any ideas?

Thanks! =)
Reply

You can no longer comment on this thread as it was closed due to no activity for a month.

Devious Comments

:iconheadz:
Headz Featured By Owner Jan 3, 2013  Professional Interface Designer
My Canon 500D doesn't appear in my devices either, but when I open Preview I can go to File and I see an 'Import from Canon 500d' option. Same in photoshop.
Reply
:iconmutanteyeball:
mutanteyeball Featured By Owner Jan 3, 2013
I tried with photoshop, and it doesn't show up there, never occurred to me to try with preview, I'll give it a go.
Thanks!
Reply
:iconheadz:
Headz Featured By Owner Jan 3, 2013  Professional Interface Designer
Yeah my photoshop keeps bugging a lot, sometimes it works sometimes it crashes right in the middle of a transfer, but Preview is flawless.
If this doesn't work for you (once I dont know which OS you have), I'm sure any other simple and free image viewing software will do the trick, as long as there's an Import option :)

Cheers
Tiago
Reply
:iconmutanteyeball:
mutanteyeball Featured By Owner Jan 3, 2013
I tried preview with no joy, but you gave me the idea to try a few other programs.
Strangely, adobe bridge works. Communicates with the camera fine, and can then open the files in photoshop.
It's weird how after years of using the EOS utility, it should suddenly stop working, I even tried re-installing it, but no luck.
Ah well, just have to use bridge from now on.

Thanks for the inspiration!
Rich. =)
Reply
:iconjuliabohemian:
Juliabohemian Featured By Owner Dec 24, 2012  Professional Photographer
Is it detecting the device properly?
Reply
:iconmutanteyeball:
mutanteyeball Featured By Owner Dec 24, 2012
No, it's not showing up at all. The camera still functions as a camera though, it just won't connect.
Reply
:iconjuliabohemian:
Juliabohemian Featured By Owner Dec 24, 2012  Professional Photographer
I wonder if your device detection driver is messed up.
Reply
:iconpr-imagery:
PR-Imagery Featured By Owner Dec 24, 2012  Hobbyist General Artist
Maybe try reinstalling the camera firmware
Reply
:iconmutanteyeball:
mutanteyeball Featured By Owner Dec 24, 2012
How do I do that?
Reply
:iconpr-imagery:
PR-Imagery Featured By Owner Dec 24, 2012  Hobbyist General Artist
Doesn't seem to be an update for your camera.

Only related threads I could find.
[link]
[link]
Reply
Add a Comment: