Shop Mobile More Submit  Join Login

Details

Closed to new replies
November 3, 2012
Link

Statistics

Replies: 0

Monoprice tablet won't click?

:iconhelloabakkus:
helloabakkus Featured By Owner Nov 3, 2012  Hobbyist Digital Artist
So I use a Monoprice TWA60 drawing tablet. It works like a dream, or rather, worked, until this morning when it suddenly started acting strangely. I unplugged it when I went to move my laptop (something Iíve done hundreds of times with no issue) and when I plugged it back in, thatís when the problems started.

Suddenly the cursor speed is extremely accelerated, and it no longer maps the entire surface of the tablet to my screen. (Where previously to have my cursor at the top left of my screen, for example, Iíd have to move the pen to the top left of the drawing surface.) Whatís more, although the cursor moves, when I tap the pen down, which usually triggers a click, nothing happens.

Iíve tried:
- restarting
- uninstalling and reinstalling the drivers
- uninstalling, running a registry cleaner, and reinstalling the drivers.
- changing the pen nib
- changing the pen battery
- trying all my usb ports

Nothing works, my warranty is long over, and buying a replacement is completely out of the question, as I am unemployed and completely broke. (In fact, digital art commissions are the only way Iím making any money right now, so this is a very serious issue.)

Any help would be extremely appreciated, as Iím at a loss for what to do.
Reply

You can no longer comment on this thread as it was closed due to no activity for a month.

Devious Comments

No comments have been added yet.

Add a Comment: