Shop Mobile More Submit  Join Login


Closed to new replies
June 25, 2009


Replies: 24

Wacom Bamboo tablet issue - holding down pen becomes right click

ThisIsMetal Featured By Owner Jun 24, 2009
My Bamboo tablet has been terribly naughty lately.

When I press the pen to the tablet and don't move the pen, or only move it a small amount, red dots circle around the cursor. If I keep holding it down and don't move the pen enough, then it will display a little right click symbol for like three seconds, and if I release then it acts like I right clicked. If I keep holding it down after, the dots work normally and it acts as expected. Which basically means that any time I want to hold a button (say, a scrollbar button) down, or drag something, or DRAW A LINE, I have to either deal with horrible initial jerkiness or wait like five minutes for it to work properly - PER CLICK. For terribly obvious reasons, this is not optimal.

Yes, I've installed the most recent driver, and I've tried rummaging through the settings. No, I can't remember when it first started doing this. I'm running Windows XP - a friend of mine with Vista claims that he found an "enable press and hold for right-clicking" toggle box, but I had no such luck.

I'd be very appreciative if anybody was able to help me here!

Devious Comments

deshrubber Featured By Owner Mar 18, 2010  Hobbyist General Artist
Necro thread. :)

Alexander750 Featured By Owner Feb 9, 2010  Student General Artist
I read through wacom's driver bulletin and I think they address this issue. If I remember correctly a driver update caused this even when the right click mode was turned off. Newest driver is supposed to fix this heres a [link] Bulletin 091 to the driver bulletin. Thankfully it's pretty concise, so it's not a huge read.
Pufferfizh Featured By Owner Sep 5, 2009
It works! Thanks for the tip. Have been thinking of how to disable the function.
pyrohmstr Featured By Owner Sep 5, 2009  Professional Artist
it's supposed to do that fyi

its not the stylus...just change the settings in windows tablet and pen settings
AxleRose Featured By Owner Sep 3, 2009
This "Press and hold to right click" was seriously giving me the irrates as well.

To disable it in Vista:

1. Start Menu > All Programs > Tablet PC > Tablet PC Pen training.
2. In the Contents menu on the left click "For more information".
3. Customizing pen settings > Pen and Input Devices.
4. Under "Pen Actions" select "Press and Hold" then click on "Settings".
5. Untick "Enable press and hold for right clicking".

DONE! No more stupid annoying Vista loading circles when holding down your pen!
Chessbo Featured By Owner Feb 6, 2010
Super thanks for this!! works on windows 7!!!
kh013 Featured By Owner Oct 5, 2009
THANK YOU SO MUCH! :heart: This was driving me INSANE...
abtxb4x67 Featured By Owner Aug 7, 2009   Interface Designer
well is there any brand beside wacom...
i've just planned to buy a graphic tablet, but it seems that it is expensive enough..
random-jimmy Featured By Owner Aug 9, 2009
There are other brands, but of course not as good.

Look on ebay for the "slim" tablets - they are a decent size and yet pretty cheap

Otherwise, buy the small 'bamboo' from wacom - i got mine for $105 AUD and it works like a charm.
ThisIsMetal Featured By Owner Jul 26, 2009
For XP - the best fix I have is to uninstall and reinstall the driver, which so far has worked for me very well.

For Vista, there's apparently a checkbox in the Tablet Properties or something?

Maybe we SHOULD contact Wacom and get a definite answer once and for all, since this seems to be a common problem!
Add a Comment: