Shop More Submit  Join Login

Details

Closed to new replies
January 5, 2013
Link

Statistics

Replies: 117

All I want to do is have some fun

:iconwitwitch:
witwitch Featured By Owner Jan 5, 2013  Student Writer
. . . playing The Sims 3.

But no. I just can't have that, can I?

I've tried fucking everything to fix my game and nothing works. Removed custom content? Check. Tried replacing the meta files in the Saves folder? Check. Deleted the cache? Check.

This is the second time I've remade this neighborhood from scratch (I delete most of the buildings including all houses with EA Sims families in them). I prefer neighborhoods that have been actually made completely by me.The few exceptions are job buildings. Some of them, anyways. This makes it the second time I've lost this content. I do not want to have to go and redesign the same neighborhood for the third time!

Luckily I have a few of my custom made buildings saved in the community lot bin . . . The new neighborhood was even saved using "save as" as suggested to avoid file corruption. Nope. Nope. Nope. The files just simply will not load! The loading screen comes up, the green bar gets to around 15 - 20% and then the music stops and the game will just sit there like that for as long as I let it.

I even tried checking to see if it was the neighborhood itself that was causing these problems. I created a new save game of the same neighborhood, derpderp.sims3, except with all EA content (it's the Monte Vista special download one). Loaded up a random family, saved it, quit, started the game up again and it loaded just peachy. What the fuck?

I just spent 6 hours playing today. I love my witch character. :heart: She just mastered the alchemy skill and learned so many new delightful recipes. Why, why, why--why is it that every time I make advancements with this particular sim family in this neighborhood that I won't be able to load my game later? I play my sims. I save using "save as". I quit for a bit. Come back later. Game refuses to load, as described above. What is wrong here? NOTHING! Nothing has changed!

I posted this in Complaints and not tech support because I fucking give up. I don't think there's any way to fix this. :crying:
Reply

You can no longer comment on this thread as it was closed due to no activity for a month.

Devious Comments

:iconpsychogizmo:
psychogizmo Featured By Owner Jan 7, 2013  Hobbyist Photographer
Read a book.
Reply
:iconshantella:
Shantella Featured By Owner Jan 7, 2013  Hobbyist General Artist
I'm more frustrated with the glitch that doesn't allow me to use the telescope. (I have all the EP's except Supernatural)
Reply
:iconwitwitch:
witwitch Featured By Owner Jan 7, 2013  Student Writer
That sounds annoying. :ohnoes:
Reply
:iconshantella:
Shantella Featured By Owner Jan 8, 2013  Hobbyist General Artist
Yeah, they'll go up to it like they're going to use it, then the action automatically stops and my sim will just be standing next to it.
Reply
:iconwitwitch:
witwitch Featured By Owner Jan 8, 2013  Student Writer
Ugh. I hate it when that happens! That happened with my alchemy station, but I fixed it by deleting the object and buying my sims a new one right after loading the save file.
Reply
:iconshantella:
Shantella Featured By Owner Jan 7, 2013  Hobbyist General Artist
And Seasons, I don't have that one either.
Reply
:iconmurphysdinnerparty:
MurphysDinnerParty Featured By Owner Jan 7, 2013  Hobbyist General Artist
I get particularly pissed because of the issues with custom content. For that reason alone is why I like The Sims 2 so much. Its kind of like a good middle ground for me.

Anyway, I did what `bohobella said. I deleted all the files in my Documents after uninstalling the game, re-installed it and now I don't have any issues.
Reply
:iconpinkmitten:
Pinkmitten Featured By Owner Jan 6, 2013
I've never played Sims. I'm afraid to play it because I don't want to like it and get addicted to it. :B
Reply
:iconactsofart:
ActsofArt Featured By Owner Jan 6, 2013  Hobbyist Traditional Artist
that's too bad. I remember how fun the Sims could be. Too bad I don't own it anymore.
Reply
:iconwhitedarkdragon2:
WhiteDarkDragon2 Featured By Owner Jan 6, 2013
Fuck, don't we have a hell of a time. Can never have a smooth running day.
Reply
Add a Comment: